TCL-X100

Fujifilm X100F: Auto Detect WCL & TCL Lenses

004_DerekClarkPhoto-WCL-TCL.jpg

If you have a Fujifilm X100F and the older mk1 WCL-X100 wide angle, and the TCL-X100 teleconverter lenses and you’re still diving into the menus or using up an Fn button to tell the camera when any of these are attached…read on.

The X100F has a magnet next to the front element of the lens (under the surface), as does each of the newer mkII lenses. So when the WCL or TCL are screwed on to the font of the camera, these two magnets react to each other and the camera automatically switches to whichever lens is attached and corrects for barrel distortion. How does the X100F know which of the two lenses are attached I here you say? Simple; The polarity of the magnets are reversed on each lens. So the magnet on one lens pulls and the other pushes. But the original two conversion lenses don’t have magnets on them.

I bought a packet of really small magnets on Amazon UK and I crudely attached them inside of the lenses next to the rear element. But they were either not strong enough or to slim. So I attached a second magnet on to of each of them, but this time just held by their on magnetic strength. They then worked as they should and although I meant to go back an do a neater job, I’ve never got round to it and the magnets have never moved at all. I might go back and use one magnet on each, with a bit of black Sugru to stick them down and raise them up at the same time.

The boxes that come with each of the conversion lenses actually have magnets inside the lids. If you don’t mind destroying your boxes you can cut these out with a sharp knife and use them.

INSTRUCTIONS

  1. Move the magnet over the front of the lens (close to the FUJINON logo).

  2. Check the viewfinder to see the point where the W or T symbol appears.

  3. Make a note if it was W or T and keep the magnet facing in the same direction (polarity).

  4. Place a piece of tape on the aperture dial where the magnet reacted (don’t move the dial).

  5. Now screw each lens and place a piece of tape on them at the same point as the camera’s

  6. Remove the lenses & attach a magnet using tape inside the back of the lens (see picture).

  7. You might need to re-check the polarity to make sure it’s correct for each lens.

  8. Screw the lenses on and check that the camera automatically switches to WCL or TCL.

  9. If the camera doesn’t automatically adjust, add another magnet on top of the first one

That’s it. No more menu diving or using up an Fn button. Plus, you’ve just saved a load of money buying the WCL or TCL mkII’s.

Good luck.